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EXCEL 
 

1.Define the following: 

a) Workbook, Worksheet 

b) Cells 

c) Number of rows and columns in a worksheet 

d) Excel File Extensions 

e) Relative reference, absolute reference 
 

a. Workbook, Worksheet 

Workbook: 

A workbook is an entire Excel file that contains one or more worksheets. By default, there are 

3 worksheets. 

Example: When you open Microsoft Excel, the file you work in (like studentmarks.xlsx) is 

called a workbook. 

Worksheet: 

A worksheet is a single page or sheet in a workbook where you can enter and organize data in 

rows and columns. 

Example: Each tab (Sheet1, Sheet2, Sheet3, etc.) inside the workbook is a worksheet.  

b. Cells 

A cell is the intersection of a row and a column in a worksheet. Each cell can contain text, 

number or formula/function. 

Example:  

The top-left cell in a worksheet is A1 (Column A, Row 1). 

c. Number of Rows and Columns in a Worksheet 

Rows: 10,48,576 

Columns: 16,384 (labeled from A to XFD) 

So, a worksheet has 10,48,576 × 16,384 possible cells. 

d. Excel File Extensions 

File Type   Extension Description 

1.Excel Workbook   .xlsx    Default Excel file format  

2.Excel 97–2003  

  Workbook    .xls            Older Excel file format 

3.CSV              .csv            Comma Separated values 

 

f. Relative Reference, Absolute Reference 



Relative Reference: 

A cell reference that changes when a formula is copied to another cell. 

Example:  

In =C2+D2+E2, if copied to the next row, it becomes =C3+D3+E3. 

Absolute Reference: 

A cell reference that does not change when a formula is copied. 

It is marked with a dollar sign ($). 

Example:  

=C$2+D$2+E$2 always refers to the same cells, no matter where the formula is copied. 

 

2. Create a data set in a new worksheet with the following columns: 

S.No., Name of the Student, Date of Birth, Age as on Today, Stream, College 

Instructions: 

a) Enter details for 10 students of your choice. 

b) Ensure DOB is entered in dd-mm-yyyy format. 

c) Keep the Age column blank for now. 

d) Set the column headings in bold and fill them with light gray background colour. 

e) Apply borders to the table. 

 

a. Enter details for 10 students of your choice 

To enter details for 10 students, click on the rows below the column headings and type each 

student’s information in the respective columns. Continue entering the remaining students 

one by one until all 10 records are completed. 

b. Ensure DOB is entered in dd-mm-yyyy format 

While entering the Date of Birth, type each date in the dd-mm-yyyy format. Make sure all 

DOB entries follow the same format for consistency.  

c. Keep the Age column blank for now 

Do not type anything in the Age as on Today column. Leave all the cells in this column 

empty as instructed. 

 

d. Set the column headings in bold and fill them with light gray background colour 

Select the entire heading row and go to the Home tab. Click Bold (B) in the Font group to 

make the text bold. Then, click the Fill Color button and choose a light gray shade to apply 

background color to the headings. 

e. Apply borders to the table 

Select the complete table including headings and student data. Go to the Home tab → Font 

group → Borders and choose All Borders to apply borders around every cell in the table. 

Output: 



S.No. 
Name of the 
Student 

Date of 
Birth 

Age as on 
Today Stream College 

1 Anil Kumar 12-03-2004   B.Com.(C.A.) IIMC 

2 Sravani Reddy 25-07-2005   BBA IIMC 

3 Mahesh Varma 09-11-2004   B.Com.(B.A.) IIMC 

4 Priya Sharma 18-01-2005   B.Sc.(DS) IIMC 

5 Kiran Teja 30-05-2004   B.Com.(C.A.) IIMC 

6 Divya Sri 14-08-2005   BBA IIMC 

7 Rohit Sai 02-02-2004   B.Com.(C.A.) IIMC 

8 Keerthana M 27-12-2005   B.Sc.(DS) IIMC 

9 Naveen Chandra 05-06-2004   B.Com.(B.A.) IIMC 

10 Abhilash 01-02-2007   B.Com.(Hons.) IIMC 

 

 

3. Copy the table created in above Question in a new sheet. Using the shortcut keys of 

keyboard, perform the following: 

a) Make the student name column bold and italic 

b) Increase the font size of DOB to 14. 

c) Fill each column with different colour of your choice with shortcut keys. 

d) Create all borders for the table. 

e) Create a thick border with each of the column. 

 

 

a. Make the student name column bold and italic 

Select the “Student Name” column, then press Ctrl + B and Ctrl + I to make the text 

bold and italic. 

b. Increase the font size of DOB to 14.  

Select the “DOB” column, then use Alt → H → F → G repeatedly to increase the font 

size until it is 14. 

 

c. Fill each column with different colour of your choice with shortcut keys.  

For each column individually: select the column, press Alt → H → H, use the arrow 

keys to choose a fill colour, and press Enter to apply it. 

 

d. Create all borders for the table.  

Select the entire table, then press Alt → H → B → A to apply all borders around 

every cell in the table. 

e. Create a thick border with each of the column.  

With the table or each column selected, press Alt → H → B → T to apply a thick 

outside border around the selection. 

Output: 

S.No. Name of the Student Date of Birth Age as on Today Stream College 

1 Anil Kumar 12-03-2004   B.Com.(C.A.) IIMC 

2 Sravani Reddy 25-07-2005   BBA IIMC 

3 Mahesh Varma 09-11-2004   B.Com.(B.A.) IIMC 



4 Priya Sharma 18-01-2005   B.Sc.(DS) IIMC 

5 Kiran Teja 30-05-2004   B.Com.(C.A.) IIMC 

6 Divya Sri 14-08-2005   BBA IIMC 

7 Rohit Sai 02-02-2004   B.Com.(C.A.) IIMC 

8 Keerthana M 27-12-2005   B.Sc.(DS) IIMC 

9 Naveen Chandra 05-06-2004   B.Com.(B.A.) IIMC 

10 Abhilesh 01-02-2007   B.Com.(Hons.) IIMC 

 

4. Copy the table created in the previous question to a new worksheet and perform the 

following tasks: 

a) Insert a new row above the table, merge the cells in that row, and enter the 

heading “Student Details – 2025.” 

b) Adjust all column widths to fit their contents. 

c) Adjust all row heights to fit their contents. 

d) Set the row height to 25 and the column width to 10. 

e) Hide the Age column and save the file. 

 

a. Insert a new row above the table, merge the cells in that row, and enter the 

heading “Student Details – 2025.”   

Copy the existing table and paste it into a new worksheet. Then insert a blank row 

above the table. Select all the cells in the first row and merge them. After merging, 

type the heading “Student Details – 2025” in the merged cell. 

 

b. Adjust all column widths to fit their contents.  

Select the entire table to adjust the column widths. Use the AutoFit Column Width  

(Home → Cells group → Format → AutoFit Column Width) option so that each 

column automatically expands or shrinks according to the longest content in that 

column. 

 

c. Adjust all row heights to fit their contents.  

Select all the rows of the table to adjust the row heights. Apply the AutoFit Row 

Height (Home → Cells group → Format → AutoFit Row Height)  option so that each 

row height automatically fits the text inside the cells. 

 

d. Set the row height to 25 and the column width to 10.  

Increase the size of the table by changing its dimensions. Set the Row Height to 25 to 

make the rows taller, and set the Column Width to 10 to make each column wider. 

 

e. Hide the Age column and save the file.  

Locate the Age column in the table, select its header, and hide it using the Hide 

option. After completing all the steps, save the worksheet to store the changes. 

 

Output: 

Student Details-2025 

S.No. 
Name of the 
Student 

Date of 
Birth Stream College 



1 Anil Kumar 
12-03-
2004 B.Com.(C.A.) IIMC 

2 Sravani Reddy 
25-07-
2005 BBA IIMC 

3 Mahesh Varma 
09-11-
2004 B.Com.(B.A.) IIMC 

4 Priya Sharma 
18-01-
2005 B.Sc.(DS) IIMC 

5 Kiran Teja 
30-05-
2004 B.Com.(C.A.) IIMC 

6 Divya Sri 
14-08-
2005 BBA IIMC 

7 Rohit Sai 
02-02-
2004 B.Com.(C.A.) IIMC 

8 Keerthana M 
27-12-
2005 B.Sc.(DS) IIMC 

9 Naveen Chandra 
05-06-
2004 B.Com.(B.A.) IIMC 

10 Abhilash 
01-02-
2007 B.Com.(Hons.) IIMC 

 

 

5. Copy the table created in above Question in a new sheet. 

a) Mention the different data types and where are they aligned in the cell. 

b) Align the text column to the centre. 

c) Wrap the College Name and location. 

d) Insert a column to the left of the table and merge all 11 rows. Give the title of the 

table of Student details. Align it vertically in the column created. 

e) Align each of the column headings to angle clockwise direction. 

a. Data types and alignment 

  To mention the data types and their alignment, first look at the values in the table. Text 

data such as names and college names are usually aligned to the left side of the cell. Number 

data and date data are aligned to the right side of the cell.  

Data Type Default Alignment 

Text Left 

Number Right 

Date Right 

 

b. Align the text column to the centre 

  To align the text column to the centre, first select the entire text column. Then go to 

Home → Alignment group → Center. This will place all the text in the middle of the cells, 

instead of the default left alignment, making the column look neat and uniform. 

c. Wrap the College Name and location 

  To wrap the College Name and location column, select the whole column where the 

college information is typed. Then go to Home → Alignment group → Wrap Text. This 



will make long text shift to the next line within the same cell so that the entire college name 

and location are visible properly. 

d. Insert and merge a column with title 

  To insert a column to the left of the table, click on the first column of the table and 

choose Insert. After the new column appears, select all 11 cells in that column. Then go to 

Home → Alignment group → Merge & Center to merge them. Type “Student Details” 

and then use Home → Alignment group → Middle Align to align the text vertically in the 

center of the merged column. 

e. Angle the column headings clockwise 

  To angle each column heading clockwise, select the entire row containing the headings. 

Then go to Home → Alignment group → Orientation → Angle Clockwise. This will tilt 

all the headings diagonally toward the right side, giving the table a clear and stylish 

appearance. 

Output: 

S.No. Name of the Student Date of Birth 

Age as 
on 

Today Stream College 

1 Anil Kumar 12-03-2004   B.Com.(C.A.) 
Indian Institute of 

Management & Commerce 

2 Sravani Reddy 25-07-2005   BBA 
Indian Institute of 

Management & Commerce 

3 Mahesh Varma 09-11-2004   B.Com.(B.A.) 
Indian Institute of 

Management & Commerce 

4 Priya Sharma 18-01-2005   B.Sc.(DS) 
Indian Institute of 

Management & Commerce 

5 Kiran Teja 30-05-2004   B.Com.(C.A.) 
Indian Institute of 

Management & Commerce 

6 Divya Sri 14-08-2005   BBA 
Indian Institute of 

Management & Commerce 

7 Rohit Sai 02-02-2004   B.Com.(C.A.) 
Indian Institute of 

Management & Commerce 

8 Keerthana M 27-12-2005   B.Sc.(DS) 
Indian Institute of 

Management & Commerce 

9 Naveen Chandra 05-06-2004   B.Com.(B.A.) 
Indian Institute of 

Management & Commerce 

10 Abhilash 01-02-2007   B.Com.(Hons.) 
Indian Institute of 

Management & Commerce 

6. Copy the table created in previous in three different sheets. 

a) Rename the sheet as “Student Details 1", "Student Details 2", “Student Details 

3" 

b) Give Tab colour as Green, Yellow and Pink to all the three tabs 

c) Delete the sheet student details-2 from the workbook. 

d) Create a copy of student details 3 and name it as "Student Details 4" 

e) Save the file as "Student details" in your system. 

a. Rename the sheets 



  To rename the sheets, go to each sheet tab at the bottom of Excel. Right-click the first 

sheet and choose Rename, then type “Student Details 1”. Do the same for the next two sheets 

by right-clicking their tabs and renaming them as “Student Details 2” and “Student Details 

3”.  

b. Apply tab colours 

  To give tab colours, right-click on the sheet tab named “Student Details 1” and choose 

Tab Color. Select the Green colour. Then right-click on the “Student Details 2” tab and 

choose Yellow, and finally right-click on the “Student Details 3” tab and choose Red. 

c. Delete Student Details 2 sheet 

  To delete the sheet “Student Details 2”, right-click on its sheet tab at the bottom of the 

Excel window. From the options shown, click Delete.  

d. Create a copy of Student Details 3 

  To create a copy of the sheet “Student Details 3”, right-click on the tab and select Move 

or Copy. In the dialog box, check the option Create a copy and click OK. A duplicate sheet 

will appear and rename this new sheet as “Student Details 4” for clarity. 

e. Save the file 

  To save the file, go to the File menu and click Save As. In the file name box, type 

“Student details” and choose the location where you want to store the file. Finally, click Save 

to save the workbook on your system. 

 

 

 

 

7. Create a table with 15 rows having the following details. 

 

 



a. Align all details to the centre of the cell. 

b. Bold the headings using short cut key. 

c. Increase the font size to 16 by using short cut key 

d. Use italics to the students names. 

e. Give colour to the columns. 

a. Align all details to the centre of the cell 

  To align all the details to the centre, first select the entire table. Then go to Home → 

Alignment → Center. This will shift all the text and numbers to the middle of the cell, making 

the table look neat and uniform. 

b. Bold the headings using shortcut key 

  To bold the headings, select the heading row of the table. Then press Ctrl + B to make 

the text bold.  

c. Increase the font size to 16 using shortcut key 

  To increase the font size to 16, select the area where you want to change the size. Then 

press Ctrl + Shift + > repeatedly until the font size reaches 16.  

d. Use italics for the students’ names 

  To apply italics to the students’ names, select all the names in the “Name of the Student” 

column. Then press Ctrl + I. This will change the selected text to italics, giving the names a 

different style. 

e. Give colour to the columns 

  To give colour to the columns, select the entire column you want to format. Then go to 

Home → Fill Color and choose the colour you want. Repeat this step for every column that 

needs colour so the table looks attractive and organised. 

Output: 

S.No. 
Name of 

the 
Student 

SEM I 

ENG II LANG BOM FA-1 DDDM 
TOTAL 
MARKS 

1 
Ravi Kiran 

S 
67 88 65 66 94 380 

2 Sreeja M 89 72 97 68 88 414 

3 
Anil 

Kumar 
78 85 69 71 90 393 

4 
Priya 

Sharma 
82 79 74 69 87 391 

5 
Mahesh 
Varma 

75 81 72 65 92 385 

6 
Lakshmi 
Deepika 

90 88 95 84 91 448 

7 
Rohit 
Reddy 

71 69 67 73 85 365 

8 Kavya Sri 84 91 86 80 89 430 

9 Nagarjuna 68 74 70 64 82 358 



10 Divya Sree 92 89 90 88 93 452 

11 
Harsha 

Vardhan 
76 70 73 72 84 375 

12 
Sneha 
Reddy 

85 87 82 83 90 427 

13 
Vinay 
Kumar 

79 77 75 71 88 390 

14 
Sanjana 

M 
88 90 85 86 92 441 

15 
Manoj 
Krishna 

73 78 71 70 83 375 

 

8. For the data given below: 

a. Format Quantity as Number with no decimals. 

b. Format Unit Price as Currency. 

c. Calculate Total Price = Quantity * Unit Price. 

d. Add currency to Total Price column. 

e. Format Purchase Date as Long Date. 

 

a. Format Quantity as Number with No Decimals 

  To format the Quantity column, first select all the quantity values. Then go to Home → 

Number group → Number. After that, set Decimal Places = 0 to display whole numbers 

only. 

b. Format Unit Price as Currency 

  Select the Unit Price column. Then go to Home → Number group → Currency. This 

will display all values with the currency symbol and two decimal places. 

c. Calculate Total Price = Quantity × Unit Price 

  Click the first cell under the Total Price column. Type the formula 

=Quantity*UnitPrice and press Enter. Then use the fill handle to drag the formula down for 

all rows to calculate the total price for each item. 

d. Add Currency to Total Price Column 



  Select the Total Price column. Then go to Home → Number group → Currency. This 

will show all total prices with the currency symbol and two decimal places. 

e. Format Purchase Date as Long Date 

  Select all the dates in the Purchase Date column. Then go to Home → Number group 

→ Number Format → Long Date. The dates will now display in full format, such as 

“Tuesday, 18 November 2025”. 

 

Output: 

S.No. 
Item 

Name 
Quantity Unit Price Total Price Purchase Date 

1 Pen 25 
 ₹                 
5.50  

 ₹                 
138.79  

Sunday, 12 January, 2025 

2 Notebook 12 
 ₹              
15.00  

 ₹                 
180.00  

Wednesday, 5 February, 2025 

3 Pencil Box 8 
 ₹              
45.25  

 ₹                 
362.00  

Saturday, 18 January, 2025 

4 
Eraser 
Pack 

41 
 ₹                 
8.75  

 ₹                 
361.81  

Saturday, 22 February, 2025 

5 Marker 30 
 ₹              
12.50  

 ₹                 
380.63  

Tuesday, 28 January, 2025 

6 Ruler 19 
 ₹                 
6.00  

 ₹                 
113.76  

Saturday, 1 March, 2025 

7 Highlighter 10 
 ₹              
25.40  

 ₹                 
254.00  

Saturday, 15 February, 2025 

8 Stapler 5 
 ₹            
120.99  

 ₹                 
604.95  

Monday, 10 March, 2025 

9 Glue Stick 31 
 ₹                 
9.35  

 ₹                 
288.26  

Monday, 17 February, 2025 

10 File Folder 40 
 ₹                 
4.75  

 ₹                 
190.00  

Saturday, 25 January, 2025 

 

9. In a new worksheet, create the following using the Fill Series (Linear) features. 

a. In Column A, enter the number 1 in the first row. Use Fill Series to continue the 

sequence up to 20 with step 1  

b. In Column B, enter the number 2 in the first row. Use Fill Series to continue the 

sequence up to 20 with step value 2. 

c. In Column C, enter the number 20 in the first row. Use Fill Series to continue the 

sequence up to 200 using step value 25. 

d. In Column D, enter the number 250. Use Fill Series to continue the sequence up to 0 

using the step value as -25. 

e. In Column E, enter the number 45. Use Fill Series to continue the sequence up to -20 

using the step value as -5. 

a. Fill Series in Column A 

  In Column A, enter the number 1 in the first row. Then select the cell, go to Home → 

Editing → Fill → Series. In the dialog box, choose Series in: Columns, Type: Linear, Step 

Value: 1, and Stop Value: 20. Click OK. The numbers 1 to 20 will fill the column 

automatically. 



b. Fill Series in Column B 

  In Column B, type 2 in the first cell. Then go to Home → Editing → Fill → Series. Select 

Series in: Columns, Type: Linear, Step Value: 2, and Stop Value: 20. Click OK. The column 

will now display 2, 4, 6, … up to 20. 

c. Fill Series in Column C 

  In Column C, type 20 in the first cell. Go to Home → Editing → Fill → Series. Choose 

Series in: Columns, Type: Linear, Step Value: 25, and Stop Value: 200. Click OK. The column 

will display 20, 45, 70, … up to 200. 

d. Fill Series in Column D 

  In Column D, enter 250 in the first cell. Then go to Home → Editing → Fill → Series. 

Select Series in: Columns, Type: Linear, Step Value: -25, and Stop Value: 0. Click OK. The 

column will show 250, 225, 200, … down to 0. 

e. Fill Series in Column E 

  In Column E, type 45 in the first cell. Go to Home → Editing → Fill → Series. Select 

Series in: Columns, Type: Linear, Step Value: -5, and Stop Value: -20. Click OK. The column 

will now display 45, 40, 35, … down to -20. 

Output: 

Column A Column B Column C Column D Column E 

1 2 20 250 45 

2 4 45 225 40 

3 6 70 200 35 

4 8 95 175 30 

5 10 120 150 25 

6 12 145 125 20 

7 14 170 100 15 

8 16 195 75 10 

9 18  50 5 

10 20  25 0 

11   0 -5 

12    -10 

13    -15 

14    -20 

15     

16     

17     

18     

19     

20     
 

 

10. In a new worksheet, create the following using Fill Series Growth Features. 

a. In Column A, enter the number 1 in the first row. Use Fill Series to continue the 

sequence up to 200 with step 2. 

b. In Column B, enter the number 2 in the first row. Use Fill Series to continue the 

sequence up to 400 with step value 2. 



c. In Column C, enter the number 3 in the first row. Use Fill Series to continue the 

sequence up to 1500 using step value 5. 

d. In Column D, enter the number 25. Use Fill Series to continue the sequence up to 

2500 using the step value as 5. 

e. In Column E, enter the number 15. Use Fill Series to continue the sequence up to -

1500 using the step value as 3. 

a. Fill Series in Column A (Type: Growth) 

  In Column A, type 1 in the first cell. Then go to Home → Editing → Fill → Series. In 

the dialog box, select Series in: Columns, Type: Growth, Step Value: 2, and Stop Value: 

200. Click OK. The sequence will fill the column using multiplication, growing the values by 

a factor of 2 until reaching 200. 

b. Fill Series in Column B (Type: Growth) 

  In Column B, enter 2 in the first cell. Go to Home → Editing → Fill → Series. Choose 

Series in: Columns, Type: Growth, Step Value: 2, and Stop Value: 400. Click OK. The numbers 

will increase by multiplying each value by 2 until 400 is reached. 

c. Fill Series in Column C (Type: Growth) 

  In Column C, type 3 in the first cell. Go to Home → Editing → Fill → Series. Select 

Series in: Columns, Type: Growth, Step Value: 5, and Stop Value: 1500. Click OK. The 

column will display numbers growing exponentially, multiplying by 5 each time until 1500 is 

reached. 

d. Fill Series in Column D (Type: Growth) 

  In Column D, enter 25 in the first cell. Then go to Home → Editing → Fill → Series. 

Choose Series in: Columns, Type: Growth, Step Value: 5, and Stop Value: 2500. Click OK. 

The sequence will grow by multiplying each value by 5 until reaching 2500. 

e. Fill Series in Column E (Type: Growth) 

  In Column E, type 15 in the first cell. Go to Home → Editing → Fill → Series. Select 

Series in: Columns, Type: Growth, Step Value: -3, and Stop Value: -1500. Click OK. The 

numbers will decrease in a growth pattern, multiplying each value by -3 until the last value is 

-1500. 

Note: Excel does not allow negative multiplication in Growth series. 

 

 

 

 



Python 

11. Write a program to print the following sentences, Hello Everyone and Welcome to 

the world of Python.  

message="Hello Everyone & Welcome to the world of Python" 

print(message) 

 

output: 

 

 

12. Write a program to print to statements “Hello World” and “I am learning Python”. 

a. Concatenate the strings b. Split the strings 

 

message1="Hello World" 

message2="I am learning Python" 

message3=message1+message2 

print("Concatenated string=", message3) 

str="one,two,three" 

words=str.split(',') 

print("Splitted words=",words) 

 

output: 

 

 

 

13. Write a program to insert student details – Name, Father’s name, Hall ticket 

number, Date of birth, age, Stream of study, College name. 

name=input("Enter your name:") 

fname=input("Enter your father's name:") 

htno=int(input("Enter your hallticket no:")) 

dob=input("Enter your data of birth:") 

stream=input("Enter your stream of study:") 



college=input("Enter your college name:") 

 

print("**********************") 

print("Name:", name) 

print("Father's Name:", fname) 

print("Hall Ticker no:", htno) 

print("Date of Birth:", dob) 

print("Stream of Study:", stream) 

print("College Name:", college) 

 

output: 

 

 

 

14. Write a program to prepare the list of rainbow colours and print the second colour 

in the "Rainbow" list. 

 

rainbow=['Violet','Indigo','Blue','Green','Yellow', 'Orange','Red'] 

print(rainbow[0]) 

 

 

 

output: 



 

 

    

15. Write a program to assign two values to the variables a and b and perform the 

mathematical operations addition, subtraction, multiplication, division, square of a 

number. 

a=int(input("Enter the value of A:")) 

b=int(input("Enter the value of B:")) 

Add=a+b 

print("Addition=",Add) 

Sub=a-b 

print("Subtraction=",Sub) 

Mult=a*b 

print("Multiplication=",Mult) 

Div=a/b 

print("Division=",Div) 

Sq=a**2 

print("Square=",Sq) 

 

output: 

 

 

 

 

 

 



 

SQL 

 

SQL> create table supplier 

   ( 

   sno varchar(2) primary key, 

   sname varchar(10), 

   item varchar(10), 

   price number(4), 

   city varchar(10) 

   ); 

Table created. 

SQL> insert into supplier values('&sno','&sname','&item',&price,'&city'); 

Enter value for sno: S1 

Enter value for sname: Suresh 

Enter value for item: Keyboard 

Enter value for price: 400 

Enter value for city: Hyderabad 

old   1: insert into supplier values('&sno','&sname','&item',&price,'&city') 

new   1: insert into supplier values('S1','Suresh','Keyboard',400,'Hyderabad') 

1 row created. 

SQL> / 

Enter value for sno: S2 

Enter value for sname: Kiran 

Enter value for item: Processor 



Enter value for price: 8000 

Enter value for city: Delhi 

old   1: insert into supplier values('&sno','&sname','&item',&price,'&city') 

new   1: insert into supplier values('S2','Kiran','Processor',8000,'Delhi') 

1 row created. 

 

SQL> / 

Enter value for sno: S3 

Enter value for sname: Mohan 

Enter value for item: Mouse 

Enter value for price: 350 

Enter value for city: Delhi 

old   1: insert into supplier values('&sno','&sname','&item',&price,'&city') 

new   1: insert into supplier values('S3','Mohan','Mouse',350,'Delhi') 

1 row created. 

 

SQL> / 

Enter value for sno: S4 

Enter value for sname: Ramesh 

Enter value for item: Processor 

Enter value for price: 9000 

Enter value for city: Banglore 

old   1: insert into supplier values('&sno','&sname','&item',&price,'&city') 

new   1: insert into supplier values('S4','Ramesh','Processor',9000,'Banglore') 

1 row created. 

SQL> / 

Enter value for sno: S5 

Enter value for sname: Manish 

Enter value for item: Printer 

Enter value for price: 6000 

Enter value for city: Mumbai 



old   1: insert into supplier values('&sno','&sname','&item',&price,'&city') 

new   1: insert into supplier values('S5','Manish','Printer',6000,'Mumbai') 

1 row created. 

 

SQL> / 

Enter value for sno: S6 

Enter value for sname: Srikanth 

Enter value for item: Processor 

Enter value for price: 8500 

Enter value for city: Chennai 

old   1: insert into supplier values('&sno','&sname','&item',&price,'&city') 

new   1: insert into supplier values('S6','Srikanth','Processor',8500,'Chennai') 

1 row created. 

 

16. Write sql query to display Supplier numbers and Supplier names whose name starts 

with ‘R’  

SQL> select sno,sname 

   from supplier 

   where sname like 'R%'; 

SNO SNAME 

------   ---------- 

S4      Ramesh 

17. Write sql query to display the name of suppliers who supply Processors and whose 

city is Delhi.  

SQL> select sname 

   from supplier 

   where item='Processor' and city='Delhi'; 

SNAME 

---------- 

Kiran 

18. Write sql query to display the names of suppliers who supply the same items as 

supplied by Ramesh.  

SQL> select sname 

   from supplier 



   where item=(select item from supplier where sname='Ramesh'); 

SNAME 

---------- 

Kiran 

Ramesh 

Srikanth 

19. Write sql query to increase the price of Keyboard by 200.  

SQL> update supplier 

   set price=price+200 

   where item='Keyboard'; 

1 row updated. 

SQL> select * from supplier; 

SNO SNAME      ITEM            PRICE CITY 

---- ---------- ---------- ---------- ---------- 

S1 Suresh     Keyboard          600      Hyderabad 

S2 Kiran      Processor          8000       Delhi 

S3 Mohan      Mouse             350      Delhi 

S4 Ramesh     Processor        9000    Banglore 

S5 Manish     Printer            6000      Mumbai 

S6 Srikanth   Processor        8500      Chennai 

20. Write sql query to display supplier numbers, Suplier names and itemprice for 

suppliers in delhi in the ascending order of itemprice. 

SQL> select sno,sname,price 

   from supplier 

   where city='Delhi' 

   order by price asc; 

SNO SNAME  PRICE 

---- ---------- ---------- 

S3 Mohan             350 

S2 Kiran            8000 


